Reply
 
LinkBack Thread Tools Search this Thread
Old Jul 4th, 2017, 14:28 PM   1
Autumn2238
Other
New BnB Member
 
Join Date: Oct 2016
Posts: 9

13 dpo and bfn... so confused


About thirteen days ago I got these weird one-sided cramps around my ovaries, and got a little stream of blood when I wiped. I was confident I was ovulating, and we bd'd the day before. Two days ago I got what looked WXACTLY like implantation bleeding, meaning I would have implanted 11 dpo. It's 13 dpo and I got a bfn. Does anyone else have late implantation stories? I feel like if I were pregnant this wouldn't be normal. I just got the exact aligned symptoms so I'm just confused...



Status: Offline
 
Old Jul 4th, 2017, 17:57 PM   2
bcuny125
Trying to conceive (TTC)
Active BnB Member
 
 
Join Date: Jul 2017
Posts: 11
Sounds pretty good. I would think it might take another two days or so to test positive.

No bfp or af here yet, and I'm around 20 dpo (unless i ovulated late- i dont temp though, thats just when Ovia app said I probably did and I had cramping.



Status: Offline
 
Old Jul 4th, 2017, 20:35 PM   3
Autumn2238
Other
New BnB Member
 
Join Date: Oct 2016
Posts: 9
Thanks, that's so uplifting to hear. Good luck and baby dust



Status: Offline
 
Old Jul 5th, 2017, 00:00 AM   4
bcuny125
Trying to conceive (TTC)
Active BnB Member
 
 
Join Date: Jul 2017
Posts: 11
Autumn have you had any other symptoms or anything? It sounds like you timed it super well.

Baby dust to you too girl



Status: Offline
 

SEO by vBSEO