Forum Rules


Reply
 
LinkBack Thread Tools Search this Thread
Old Feb 10th, 2013, 04:40 AM   1
Ashy91
Trying to conceive (TTC)
New BnB member
 
Join Date: Feb 2013
Posts: 2

I really need some advice!!


Ok so here is what's happened.... AF arrived on the 3rd of January, I didn't track that month but I have a 30 day cycle and ovulation is usually right on time.... So that should have made it the 16th-17th...

On the 20th I started spotting brown blood, 13 days early.... It lasted for the 13 days, but at some points it was really light almost non existent, and was a light pink, and then ranged to a really think and brown.....
I cramped up badly on day 13 an the next day (2nd of Feb) what I assumed was my period showed up, was medium to heavy and lasted for two days until the light brown spotting returned for another two days..... Then nothing

It's been 5 days, and since then I can feel a twinge every now and then in my abdomen, enough to make me cringe and I just feel..... Strange

I took a HPT on the 29th of Jan and was defs negative....

Has anyone else had something like this and maybe be able to shed a little bit of light for me??



Status: Offline
 
Old Feb 10th, 2013, 18:28 PM   2
Louislugger
Trying to conceive (TTC)
New BnB Member
 
 
Join Date: Feb 2013
Location: Louisville, KY USA
Posts: 5
I have been spotting early the last 2 months. Before that, when on the pill, would often spot sometimes 10 days before really starting.
I am over 35, and came to find out after asking lots of questions at my most recent exam, for my age this (spotting) is normal due to the possibility of weak uterine lining at this point. In my case, it is only 5-6 days. Hope this helps.



Status: Offline
 

SEO by vBSEO