Have i got a water infection or not?

Discussion in 'Pregnancy - Second Trimester' started by Fabby, Sep 7, 2010.

  1. Fabby

    Fabby mummy to my amazing boy x

    Joined:
    Jul 27, 2010
    Messages:
    3,497
    Likes Received:
    0
    yesterday i saw the consultant for my underactive thyroid and at the same time he tested my waters. There was protein found in the sample and they said they were sending it off to the lab to be tested further. Last night i was out of bed so many times for the toilet, my bladder hurting, feeling like i need to pee alot more than what is actually coming out, back ache... got alot of the symptoms to relate to a water infection. So this morning, i called my doctors to see if they could get the results back asap and they said bring them a water sample to them straight away and they will test there and then and subscribe some anti-biotics. I did this and they say the water test is all fine today.....

    What else could be wrong with me do you think? Anyone experienced this?
     
  2. v2007

    v2007 Well-Known Member

    Joined:
    Jul 16, 2008
    Messages:
    28,554
    Likes Received:
    0
    It does sound like you have Cystitis.

    Take lots of Cranberry Juice and Cystitis relief powders.

    Lots of water to flush it our as well.

    :hugs::hugs:

    V xxx
     
  3. Fabby

    Fabby mummy to my amazing boy x

    Joined:
    Jul 27, 2010
    Messages:
    3,497
    Likes Received:
    0
    would that no show up in my water sample though? Im just really confused cos yesterday there was traces of an infection and today there isn't yet i feel worse today and had a really bad night with it last night
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice