Implantation Bleeding? Or am I just going crazy?!

Discussion in 'Two Week Wait' started by DemiMae, Jun 1, 2011.

  1. DemiMae

    DemiMae Guest

    Okay so it's my first time on here, this is my first post - so... Hello Everyone!

    I ovulated on the 19th May.

    At 9 dpo, I had really sharp twinges in my uterus, all the way to my groin.
    At 10 dpo my breasts began to swell and hurt (they still do today at 13dpo, only have gotten worse).
    At 11 dpo I went to pee and found a fairly small amount of brown discharge in my underwear. It wasn't there when I wiped and it hasn't been there since and my period hasn't arrived. That was 5 days before AF is due to arrive.

    Just think I should say that the above is very unusual for me and I never get this before my period and also I'm always regular within 2 days :)

    Today I'm at 13 dpo and AF is due in two days. I have had a serious stomach upset too, but don't think it was morning sickness because I was vomiting ALL night long and my OH got it too.

    Did any of you experience this then get your BFP?? Or am I just going mad?
     
  2. jamhs

    jamhs Well-Known Member

    Joined:
    May 4, 2011
    Messages:
    1,493
    Likes Received:
    0
    Let me know how you get on! Fx for you!
     
  3. HopefulTTC2

    HopefulTTC2 Dropping The Pounds(;

    Joined:
    May 23, 2011
    Messages:
    105
    Likes Received:
    0
    Im 13 dpo. With the same scarce brown dischage in my underwear. Mine wasnt exactly brown. It was really light brown, just dark enough to tell a difference. But none since. But Im due for AF tomorrow. So lets hope this is good for both of us!(;
    Sorry I couldnt answer your question, but atleast you know your not alone lol!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice