Lost my mucus plug!

Discussion in 'Pregnancy - Third Trimester' started by gilliankelly, Sep 6, 2007.

  1. gilliankelly

    gilliankelly Well-Known Member

    Joined:
    Jul 31, 2007
    Messages:
    81
    Likes Received:
    0
    OK. I received a membrane sweep yesterday, and today I've finally lost my mucus plus (got the horrible gooey, greenish and brownish deposit) I'm 40+2-weeks!

    How soon after losing you mucus plugs did labour begin???
     
  2. Wobbles

    Wobbles BnB Co-Founder ~ Retired

    Joined:
    Aug 31, 2006
    Messages:
    90,191
    Likes Received:
    40
    Sounds a nice experience lol

    I've no idea though :blush:
     
  3. angiemum2b

    angiemum2b Well-Known Member

    Joined:
    Sep 14, 2006
    Messages:
    92
    Likes Received:
    0
    i had my sweep on a tuesday morning and he was born on thursday morning.

    So it was great and effective for me!:headspin:

    Good luck x
     
  4. gilliankelly

    gilliankelly Well-Known Member

    Joined:
    Jul 31, 2007
    Messages:
    81
    Likes Received:
    0
    Ohhh! How far along were you when you had your sweep. I'm 40+2-weeks.
     
  5. Lucy

    Lucy Well-Known Member

    Joined:
    Jan 7, 2007
    Messages:
    473
    Likes Received:
    0
    Hi Gillian

    I had a sweep at 40 + 3 and went into labour that night, I lost my plug about 8 hours after the sweep.

    Good luck!
     
  6. KX

    KX Well-Known Member

    Joined:
    Sep 1, 2006
    Messages:
    5,050
    Likes Received:
    0
    Good luck hun xxx
     
  7. Hels

    Hels Well-Known Member

    Joined:
    Nov 7, 2006
    Messages:
    861
    Likes Received:
    0
    I had some mild contractions, then I lost my Muscus plug about an hour later. I was having regular contractions about 3 hours later.
     
  8. angiemum2b

    angiemum2b Well-Known Member

    Joined:
    Sep 14, 2006
    Messages:
    92
    Likes Received:
    0

    hey i was exactly 41 weeks and had him at 41+2

    Fingers crossed for you hunni:hugs:
     
  9. Tilly

    Tilly Guest

    Well I started having contractions very soon after losing mine I think (it's sometimes hard to tell the order with me as I was in pain days before I actually gave birth). I lost my plug at 5:30am and gave birth at 7:10pm that evening.

    Good luck :)
     
  10. RachieH

    RachieH Well-Known Member

    Joined:
    Sep 1, 2006
    Messages:
    1,203
    Likes Received:
    0
    Oooooh I hope its not long for you now!

    I had a show at 2am with Ky and I'd had him by 9:30am.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice