Mucous plug - have to be bloody?

Discussion in 'Pregnancy - Third Trimester' started by Bluewings, Oct 6, 2013.

  1. Bluewings

    Bluewings Blessed Twice

    Joined:
    Nov 17, 2012
    Messages:
    1,209
    Likes Received:
    0
    Subject says it all.

    I had a glop in the toilet bowl and a large quantity of glop on my paper but none of it was bloody or even tinged. In fact it was colored by my urine. Sorry for TMI!

    Is this my plug or is this just an unusual amount of discharge?
     
  2. nullaby

    nullaby Well-Known Member

    Joined:
    Jan 25, 2009
    Messages:
    2,383
    Likes Received:
    0
    Sounds like your plug, I had this yesterday and more today. I think if its bloody it could be because cervix is changing. No blood in mine, but last time I started to lose it labor was a few days away but it also regenerates.
     
  3. Cccbb61013

    Cccbb61013 Well-Known Member

    Joined:
    Apr 25, 2013
    Messages:
    690
    Likes Received:
    0
    No. You can lose bits & pieces of your plug for months. No blood has to be in it. I read the other day when you do have your bloody show, labor is days away. I've been trying to find out if there is any truth to that.


    Edit::: oops, I didn't mean no it wasnt your plug, just meant no, it doesn't have to have blood in it!
     
  4. Bluewings

    Bluewings Blessed Twice

    Joined:
    Nov 17, 2012
    Messages:
    1,209
    Likes Received:
    0
    Thanks girls!

    I've been losing it for a while, as I understand it. I figured it kept regenerating but this was a much larger glob (well two globs!) than usual. I probably missed it with my last pregnancy because I always thought it had to be bloody! Oops!
     
  5. Clo

    Clo mum 2 an angel boy, and 2 rainbow boys

    Joined:
    Jun 6, 2009
    Messages:
    1,925
    Likes Received:
    1
    Mine wasnt bloody in my last pregnancy. I lost it in bits and pieces over 2 weeks I think and when I went into labour I hadnt had a bloody show. Xxx
     
  6. steph.

    steph. Two little girls!

    Joined:
    May 27, 2011
    Messages:
    3,809
    Likes Received:
    0
    Last pregnancy (and this one too) i've been losing blobs here and there, but at 37+2 after a long walk I lost a much bigger blob. It didnt have blood in it, and the midwife told me it didnt mean anything, but I went into labour the following day.
     
  7. Louise88

    Louise88 Dd- ciara and ds- James

    Joined:
    Oct 15, 2011
    Messages:
    2,815
    Likes Received:
    0
    I lost my plug in 3 parts with my dd 10 days before I have birth lost a big bit no blood or tinged, 3 days after that I lost a smaller bit again no blood or tinged and the bloody show bit came out with my waters. I'd say it sounds like your plug you might have the bloody show with your waters like I did :)
     
  8. Kirstiedenman

    Kirstiedenman Well-Known Member

    Joined:
    Mar 2, 2011
    Messages:
    3,293
    Likes Received:
    0
    I lost mine for a week or so leading up to my labor and then the day before I went into labor I kept losing huge chunks and the night before labor I had my bloody show. Good luck fx it's not to much longer for you
     
  9. ClairAye

    ClairAye Mum to one of each!

    Joined:
    Nov 8, 2011
    Messages:
    10,922
    Likes Received:
    160
    I lost mine from 35-40 weeks and not once was it bloody.
     
  10. iluvmyfamily

    iluvmyfamily mom to 5 babies 1 angel

    Joined:
    Aug 1, 2012
    Messages:
    4,246
    Likes Received:
    0
    It IS your plug but I'm not sure if it means anything. Usually if it's bloody it means your cervix is changing. It happened to me at 38 weeks and from then on for a whole week I had contractions and I knew it was opening me up. When I hit 39 weeks I went into labor and was 7cm by the time I got to L&D. Prior to bleeding at 38 weeks, I had what you described so it's definitely mucus plug but without blood in it, it can regenerate.
     
  11. Bluewings

    Bluewings Blessed Twice

    Joined:
    Nov 17, 2012
    Messages:
    1,209
    Likes Received:
    0
    Sounds like my body is just practicing lots then! Lol. I've been losin my plug for about a month (and I'm only 36w!) but I also have contractions every day (not close at all).

    Thanks girls!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice