EPO but no EWCM?

Discussion in 'Trying To Conceive' started by Jaxvipe, Dec 21, 2009.

  1. Jaxvipe

    Jaxvipe Mom to Avianna

    Joined:
    Aug 11, 2009
    Messages:
    1,745
    Likes Received:
    0
    Hello =)

    I've been taking 1000mg of EPO this whole cycle and am due to O any day now, but i have not gotten any EWCM... Has this happened to anyone else?
     
  2. Jaxvipe

    Jaxvipe Mom to Avianna

    Joined:
    Aug 11, 2009
    Messages:
    1,745
    Likes Received:
    0
  3. WannaB

    WannaB Busy Finding Nirvana!

    Joined:
    Sep 12, 2009
    Messages:
    5,362
    Likes Received:
    0
    Ive never used it tbh and I dont get much cm at all but it doesnt seem to matter, Ive managed to conceived twice in four cycles, so dont stress too much about not having any!:hugs:
     
  4. Jaxvipe

    Jaxvipe Mom to Avianna

    Joined:
    Aug 11, 2009
    Messages:
    1,745
    Likes Received:
    0
    yea, i had tons of lotiony cm but it seems like the day after we BD there is no CM at all which i guess would be a good thing because that would be it was all getting "sucked up'' into my uterus iykwim... it so hard not to worry lol
     
  5. WannaB

    WannaB Busy Finding Nirvana!

    Joined:
    Sep 12, 2009
    Messages:
    5,362
    Likes Received:
    0
    As long as your not dry as a bone down there, you will be fine!:thumbup: I only get wet during sex, but that is still fertile cm and good enough to transport the little buggers to where they need to go!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice