Anyone had something similar

Discussion in 'Pregnancy - First Trimester' started by MrsCM, Nov 15, 2011.

  1. MrsCM

    MrsCM Active Member

    Joined:
    Sep 28, 2011
    Messages:
    27
    Likes Received:
    0
    Hi everyone. Need some help and advice. I had some lite bleeding and alot of brown discharge. So today I go to the docs to get some answers. I was told I'm likely mis carrying but to keep thinking I'm pregnant but it looks like I'm losing the baby, and because i dont feel pregnant or have any sumptoms!! ( inever said i didnt feel pregnant and my symptoms are very minor!) I was then sent for a scan, external and internal. They saw something but aren't 100% sure. So going back next week. They took blood also and have to take another blood test on wed. The doc who took my scan said its 50/50. I feel fine. I'm not upset or worried anymore. Anyone experienced this yet? I'm meant to be due on the 8th July. Thanks xx
     
  2. TunechisMom

    TunechisMom Well-Known Member

    Joined:
    Oct 6, 2011
    Messages:
    200
    Likes Received:
    0
    Didn't want to R&R but I hope all is well.
     
  3. threemakefive

    threemakefive Well-Known Member

    Joined:
    Oct 29, 2011
    Messages:
    1,564
    Likes Received:
    0
    My first sono was the same well all three of them turns out I was just earlier than we thought...keep your chin up!
     
  4. mom and ttc

    mom and ttc Well-Known Member

    Joined:
    May 12, 2011
    Messages:
    2,893
    Likes Received:
    0
    When I had my MC there was crazy amounts of blood and cloths and severe cramping. Hope everything goes well
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice