Pain after ERPC

Discussion in 'Miscarriage Support' started by Lou123, Sep 18, 2007.

  1. Lou123

    Lou123 Active Member

    Joined:
    Sep 17, 2007
    Messages:
    25
    Likes Received:
    0
    Hi

    I had the ERPC procedure last Friday. From Sunday, I have been experiencing very excruciating pains (on/off) in my abdomen, lower pelvis in particular. They come and go. Sunday was very bad but yesterday was better and I only had a few. However, since this morning they've picked up again and when they hit me, I'm bent over in agony.

    At first I thought it could have been something simple like constipation following the procedure - but it's not because my bowels are now operating just fine. I went to see my GP yesterday and he prescribed me two courses of antibiotics saying that I could possibly have an infection - even though I have no temperature or the typical sympton of smelly discharge. I still have light bleeding following the surgery.

    The antibiotics don't seem to have had any effect yet and I was just wondering if anyone else had experienced similar symptons? I just want this whole nightmare to be over!

    Thanks

    Lou
     
  2. Wobbles

    Wobbles WoBbLeWoBbLe
    Administrator

    Joined:
    Aug 31, 2006
    Messages:
    99,772
    Likes Received:
    15
    Discomfort could be present sadly :hugs: If your in servere pain I would seek some medical advise though Lou

    x
     
  3. Lou123

    Lou123 Active Member

    Joined:
    Sep 17, 2007
    Messages:
    25
    Likes Received:
    0
    Thanks - I will give the antibiotics another day or so and if still experiencing pain then I will go back to GP.

    Lou
     

Share This Page